directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ole Ersoy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSERVER-751) Jsvc fails on AMD 64-bit linux machines
Date Thu, 19 Apr 2007 20:07:15 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-751?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12490157
] 

Ole Ersoy commented on DIRSERVER-751:
-------------------------------------

Oh - I should also mention that I'm running 1.5.0
on AMD 64.  When I first tried to run it,
it did not want to start, even though
I su'd from my account.

>From what I understand, su give me root priviliges,
but does not make me the root user.

So I tried again from the "root" user shell,
and as long as I set JAVA_HOME 
it runs fine.

When the RPM installer gets done, ApacheDS will run under the user "apacheds",
so we may want to wait on this, unless it's really urgent for someone.

Cheers,
- Ole





> Jsvc fails on AMD 64-bit linux machines
> ---------------------------------------
>
>                 Key: DIRSERVER-751
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-751
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 1.0.1, 1.5.0, 1.0, 1.0-RC4, 1.0-RC3, 1.0-RC2, 1.0-RC1, pre-1.0
>         Environment: AMD 64
> Ubuntu 6.06.1
> JDK 1.5.0_08
>            Reporter: Alex Karasulu
>         Assigned To: Alex Karasulu
>            Priority: Minor
>             Fix For: 1.5.1, 1.0.2
>
>
> The apacheds start command on the init script fails because the compiled binary for Jsvc
segfaults on 64-bit machines.  I think we need a 64-bit version of ApacheDS installers with
a jsvc binary compiled on a 64-bit linux machine.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message