directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: Curious bug with 1.5.0...
Date Thu, 29 Mar 2007 01:55:43 GMT
Hi Emmanuel,

On 3/28/07, Emmanuel Lecharny <elecharny@gmail.com> wrote:
>
> Hi guys,
>
> I'm experiencing a very strange bug with the latest version of ADS 1.5.0(the one we are
currently voting), and this is a strange bug because I don't
> get the error on a linux computer, only on my mac OSx, with the latest java
> version ( 1.5.0-07-164). It seems that the
> java.naming.ldap.attributes.binary property is not set at all on my
> computer, and I get a warning when launching the server :
>
> WARN [org.apache.directory.shared.ldap.message.MessageDecoder ] - Could
> not find java.naming.ldap.attributes.binary key in environment.  Using
> empty set for binaries.
>
> I never had this error before, so I suspect it to be related to Apple jvm,
> which has been updated recently on my mac.


Hmmmm yeah that does sound weird.  Can you confirm that you're not getting
this message definitely on other platforms?

However, the server code was not very deffensive when this environment
> variable was not set, so I have fixed it.


Oh good.

I'm just puzzled that it exploded in my face only today.
>
> Anyone ever experinced the very same problem ?


I cannot recall experiencing it but I have not been on my mac with macosx
running in a while. I run ubuntu ppc on my mac (please do no flame me for
this).  I can test it in a day or so if you need me to so.  Just let me
know.

Alex

Mime
View raw message