directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Norval Hope (JIRA)" <j...@apache.org>
Subject [jira] Created: (DIRSERVER-873) Apparent problem in decoding LDAP requests
Date Fri, 16 Mar 2007 06:01:09 GMT
Apparent problem in decoding LDAP requests
------------------------------------------

                 Key: DIRSERVER-873
                 URL: https://issues.apache.org/jira/browse/DIRSERVER-873
             Project: Directory ApacheDS
          Issue Type: Bug
          Components: asn1, ldap
    Affects Versions: 1.5.0
         Environment: WindowsXP, JDK 1.5.06
            Reporter: Norval Hope


I'm sending a request with a non-seven bit ascii char in a DN from JXplorer and it seems to
be decoded incorrectly when it arrives at ApacheDS (ASN level byte logging is attached). I
see the same problem when sending the request from JMeter too.

The DN I used was "uid=tté,ou=system" (same as uid= value in attributes) but decoded as 'uid=tt\C3\A9,ou=system'
where I was expecting 'uid=tt\E9,ou=system'. The full data I sent was:

DN: uid=tté,ou=system
cn: tté
objectClass: inetOrgPerson
sn: ttsn

I tried sending the DN as 'uid=tt\E9,ou=system' but then JXplorer tried to quote the '\' itself
so it seems that it wants to be responsible for the conversion to an rfc2253 compliant DN
itself.

I know all this encoding/codepage/locale/lang stuff is always a big PITA and that this may
be related to to the default encoding on WinXP or some such thing, but even then I'm struggling
to see how one Latin char 'é' becomes two hex chars \C3 and \A9 in UTF8. At any rate I have
attached the ASN byte logs so that someone more knowledgeable can review and state definitively
that the bytes received by AD are already "bad". Note that I ran this test against the latest
1.5 trunks (after first noticing the issue in my own out-of-date a heavily modified version
of 1.5)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message