directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: apache DS 1.0.0 and JSK 1.4 or 1.5
Date Thu, 30 Nov 2006 23:38:27 GMT
Gianmaria Clerici a écrit :

>Quick question.
>
> 
>
>I should be able to build 1.0.0 with either 1.4 or 1.5
>
>And I should also be able to run it with either 1.4 or 1.5
>
> 
>
>Is that correct ?
>  
>
Nope. You need java 5 to compile ADS 1.0.0, because it depends on MINA 
and MINA needs to be compiled with Java 5 in order to have SSL working. 
However, the generated code is jdk 1.4 compatible.

> 
>
>I am having problem when building with 1.4. it builds ok but I can't run
>it.
>
> 
>
>It seems that I can only get it to work when I build and run with 1.5.
>  
>
You should be able to build it with 1.5 and make it work with 1.4.

If this is not the case, please open a JIRA with teh exact steps you 
used and the exact configuration you are using.

Thanks !

Emmanuel

Mime
View raw message