directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Malcolm Gorman" <M.Gor...@bom.gov.au>
Subject RE: Windows LDAP Clients Hanging - DS 1.0
Date Mon, 27 Nov 2006 22:26:29 GMT
How do I unsubscribe from this list? I've tried the usual way but it
hasn't worked.
 
 
Malcolm Gorman          m.gorman@bom.gov.au <mailto:m.gorman@bom.gov.au>

Phone (03) 9669 4846    FAX (03) 9669 4128
700 Collins Street      GPO Box 1289 
Docklands, VIC 3008     Melbourne, VIC 3001
Intranet: http://servb.ho/~mal <http://servb.ho/~mal>  
http://web.bom.gov.au/~mal/tsunami
 


________________________________

	From: Simon.Temple@saaconsultants.com
[mailto:Simon.Temple@saaconsultants.com] 
	Sent: Tuesday, 28 November 2006 02:13
	To: Apache Directory Developers List
	Subject: Re: Windows LDAP Clients Hanging - DS 1.0
	
	
	
	Emmanuel
	 
	1.  The 1.5 class in the test case:
	 
	
C:\work\_SVN_PROJECTS\apache\directory\shared\0.9.5\ldap\src\test\java\o
rg\apache\directory\shared\ldap\name\LdapDNTest.
	java:[43,25] cannot resolve symbol
	symbol  : class LdapName
	location: package ldap
	 
	2.  I use JXplorer (build JXv3.1) and custom java code and do
not experience problems searching the V1.0 or V1.0.1.
	 
	3.  The reason I am using ldp.exe is that the WIndows team
within my company, report that their existing search code now hangs with
V1.0 (it did not with 1.0-RC3) and I just needed a way of using the
wldap32.dll in isolation. ( To prove the problem ).
	 
	4.  I have requested our Windows team provide me with a simple
program which highlights the issue.  It is my intention to prove the
problem does not exist with 1.0-RC3 and does now exists in 1.0.  I will
obviously forward you the log output from both versions of DS and supply
the Windows code for reference.
	 
	5.  I'll also build LdapStudio while I'm waiting and just
confirm it works fine... I'm sure it will  :-)
	 
	SimonT
	 
	27 November 2006 14:16
	To: "Apache Directory Developers List"
<dev@directory.apache.org>
	cc: 
	From: "Emmanuel Lecharny" <elecharny@gmail.com>
	Subject: Re: Windows LDAP Clients Hanging - DS 1.0
	
	


	On 11/27/06, Simon.Temple@saaconsultants.com <
Simon.Temple@saaconsultants.com <mailto:Simon.Temple@saaconsultants.com>
> wrote: 

		
		Emmanuel
		
		The client is a windows program called ldp v3 (it uses
wldap32.dll).
		 
		Its here:
http://www.computerperformance.co.uk/w2k3/utilities/ldp.htm
		 
		You are correct, it is performing a search for rootDSE.
		 
		On the subject of test cases.  I found that I could not
build directory-shared becuase \shared\0.9.5\ldap\src\test has
references to a Java 1.5 class :-(


	Sh!t ! Which class ? 
	


		
		To clarify, the server is *not* hanging... the client is
hanging, waiting for a response to the search.


	Hmmm... I think that may be the client receive a response that
doesn't make the client happy. Requesting for rootDSE is something we
know works. Could you try LdapStudio ? It's a project which contains a
Ldapbrowser (not finished yet, but starting to work) : 
	
	svn co
http://svn.apache.org/repos/asf/directory/sandbox/pamarcelot/ldapstudio
	
	You will need to install ant 1.6.5 plus install the
ivy-1.4.1.jar library in ANT_HOME/lib to be able to build it.
	
	To build LdapStudio : just type 'ant' (yeah :)
	
	The result will be in target/Ldap Studio/Ldap Studio
	
	You will be able to request rootDSE with this tool without any
pb. 
	


		
		If I can help anymore, please ask.


	I'm pretty sure that the client (ldp V3) is by no mean the best
ever... Except if you really have to send requests in batch mode. Just
try the very same request with LdapBrowser and JExplorer, and tell me if
it's better. 
	
	Emmanuel



Mime
View raw message