directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Kranz <p.kr...@ekits.de>
Subject Generating a custom schema
Date Tue, 14 Nov 2006 16:13:09 GMT
Hi list,

I'm trying to generate a custom schema for penrose. Since penrose uses
Apache DS in the backend I need to generate my schema for Apache DS.
I have to admit, that I have no experience with Apache DS or maven, at
least not yet :)

I followed the documentation found in the wiki
(http://cwiki.apache.org/confluence/display/DIRxSRVx10/Custom+Schema)
and just finished my round through the mailing list archives.

But I'm sorry to say, that I still have a problem. I installed maven
2.0.4 and subversion and made a checkout of schema-archetype as told by
the wiki. But when I try to execute "mvn install" I get the following
error:

[INFO] Scanning for projects...
[INFO]
----------------------------------------------------------------------------
[INFO] Building ApacheDS Schema Archetype
[INFO]    task-segment: [install]
[INFO]
----------------------------------------------------------------------------
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.apache.maven.plugins:maven-plugin-plugin

Reason: Error getting POM for
'org.apache.maven.plugins:maven-plugin-plugin' from the repository:
Failed to resolve artifact, possibly due to a repository list that is
not appropriately equipped for this artifact's metadata.
  org.apache.maven.plugins:maven-plugin-plugin:pom:2.2-SNAPSHOT

from the specified remote repositories:
  apache.snapshots (http://people.apache.org/maven-snapshot-repository),
  snapshots (http://snapshots.repository.codehaus.org),
  central (http://repo1.maven.org/maven2)



[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Tue Nov 14 17:02:33 CET 2006
[INFO] Final Memory: 1M/4M
[INFO]
------------------------------------------------------------------------

It seems like maven is simply not able to find a file in the internet
but since I never used maven before I really don't have any idea where
to look to correct this behaviour. Perhaps it is time now to replace my
Ant book on the shelf with the appropriate maven literature (and read it
of course :)

I am grateful for every help.

Greetings,
Patrick



Mime
View raw message