directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny" <elecha...@gmail.com>
Subject Closing: [VOTE] java 5 ?
Date Thu, 26 Oct 2006 16:44:07 GMT
Hi gang,

two weeks ago, a VOTE has been launched : shall we migrate to Java 5 and
when ?

Here are the results :

10 [X] Let's use java 5 right now in 1.1 version (which is currently the
trunk), and this will become the 1.5 release
2 [X] 1.1, 1.2 ... should remain 1.4 compatible. However, let's create
a 1.5branch for java 5

With 9 binding votes for proposition 1, and 1 non binding vote
and 1 binding vote and one non binding vote for proposition 2

I forgot to vote myself, but I vote for poroposition 1 (and the counting
included this vote)

I guess that we may use Java 5 cool features on the trunk and get rid of all
jdk 1.4 compatiility ugliness right now.

Note that we won't rewrite the full server code in Java 5, but cmmitters may
feel free to use enums, auto-bocing, generics and all other features :)

Emmanuel

Mime
View raw message