directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon.Tem...@saaconsultants.com
Subject Re: WARN: Attribute does not have normalizer
Date Tue, 17 Oct 2006 13:20:23 GMT
Emmanuel

Thanks for the prompt reply.

1.  IMHO, a level of INFO would be better for the 'normalizer' entries - would you agree?
 My users are equally sensitive to both ERROR and WARN log entries.

2.  I think the BTreePartition WARNs could be avoided if the code that creates the system
partition explicitly sets the cache size on the index attributes.
     I know this as I create a custom partition and it was generating WARN messages!  I see
from the Spring configuration file that it sets the index
     attributes.  Is there a way to ensure the system partition sets the index attributes
when I'm not using Spring?

Thanks

Simon T


17 October 2006 13:53
To: "Apache Directory Developers List" <dev@directory.apache.org>
cc: 
From: "Emmanuel Lecharny" <elecharny@gmail.com>
Subject: Re: WARN: Attribute does not have normalizer


Hi !

So far, you haven't done anything wrong. The warnings are just here to warn about the fact
that, as we don't have declared any normalizer for sme attributes, ADS will just use a kind
of Identity normalizer (ie, a normalizer that don't normalize :). It's always possible to
declare some normalizer into the schema files, but I'm not sure this is necessary to normalize
a photo (!?), for instance. 

FYI, normalizer are used to transform an attribute value in a way that allow comparizons between
values. For instance, if an attribute is case insensitive, then the normalization will transform
the value to a lower cased string, and every further comparizons will be done using lower
cased comparizons. 

I think that you just get more logs just because 1.0 is just a little bit more verbose.

Emmanuel


On 10/17/06, Simon.Temple@saaconsultants.com <Simon.Temple@saaconsultants.com> wrote:
I just installed the latest V1.0 release on Windows.

I'm running DS embedded in jBoss.  I am experiencing a number of log4j warnings that I did
not see in RC3.

The first batch or WARNs seem to relate to the Bootstrap schema loader and the second batch
relate to the creation of the system partition.

What have I done wrong?

<snip>
BootstrapAttributeTypeRegistry) Attribute teletexTerminalIdentifier does not have normalizer
: using NoopNormalizer
BootstrapAttributeTypeRegistry) Attribute photo does not have normalizer : using NoopNormalizer
BootstrapAttributeTypeRegistry) Attribute facsimileTelephoneNumber does not have normalizer
: using NoopNormalizer

BTreePartition) Using default cache size of 100 for index on attribute objectClass
BTreePartition) Using default cache size of 100 for index on attribute 1.2.6.1.4.1.18060.1.1.1.3.4
BTreePartition) Using default cache size of 100 for index on attribute 1.2.6.1.4.1.18060.1.1.1.3.1
<snip>


TIA

Simon T



-- 
Cordialement,
Emmanuel L├ęcharny 
Mime
View raw message