directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ersin Er" <ersin...@gmail.com>
Subject Re: updating spring 1.2.1 to 1.2.8?
Date Tue, 05 Sep 2006 17:27:04 GMT
Hi,

On 9/5/06, Bastiaan Bakker <bastiaan.bakker@enovation.nl> wrote:
> On Tue, 2006-09-05 at 19:57 +0300, Ersin Er wrote:
> > Hello Bastiaan,
> >
> > We have just tried to upgrade Spring to version 1.2.8 but because it's
> > not deployed to ibiblio mirrors yet we could not do a successfull
> > build.
>
> Thanks for the explanation, but could you clarify it a bit more. I'm not
> very familiar yet with the locations of the proper maven2 repos, so
> forgive me for the newbie questions.
> I see that apacheds uses groupid 'springframework' and that
> http://www.ibiblio.org/maven2/springframework has only 1.2.6 as the
> newest release (which is still better than 1.2.1)
> But looking at http://www.ibiblio.org/maven2/org/springframework/ I do
> see the 1.2.8 release.
> Any reason why apacheds uses groupid 'springframework' rather than
> 'org.springframework'?

There is no reason for using springframework groupid. It was the valid
one in the past and we were aware of that's changed. So thanks for the
right location. We are going to upgrade to Spring 1.2.8 ASAP but not
sooner than 1.0-RC4. We would really like to do that we cannot do a
last minute change now. ApacheDS 1.0-RC4 will be out in a few minutes
:-)

(But feel free to upgrade Spring in your local. As this is open source
software you have the full power.)

Cheers,

> Regards,
>
> Bastiaan
>
> > We are going to try in the next release again.
> >
> > Cheers,
> >
> > On 9/5/06, Bastiaan Bakker <bastiaan.bakker@enovation.nl> wrote:
> > > Hi,
> > >
> > > We use ApacheDS to update a relational user database via LDAP. The
> > > custom ApacheDS backend needs some methods that have been introduced
> > > into Spring after 1.2.1.
> > > Is there any reason why ApacheDS is still using Spring 1.2.1? This
> > > version is over a year old. The current 1.2.8 release has numerous
> > > bugfixes over the old one.
> > > Could 1.0RC4 be build with 1.2.8? If not what's holding it back?
> > >
> > > Best regards,
> > >
> > > Bastiaan Bakker
> > > E.Novation LifeLine Networks bv
> > >
> > >
> > >
> >
> >
>
>


-- 
Ersin

Mime
View raw message