directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject [VOTE] Release MINA 0.9.5
Date Sat, 02 Sep 2006 22:26:25 GMT
Hi all,

We have the same dependency issue as last time with ApacheDS and MINA 
where a dep on shared-asn1 is forcing us to have to release MINA in 
order to release ApacheDS.  We really need to find a solution to this 
problem for the next MINA/ApacheDS release.  For now here's the problem 
in detail:

MINA's 0.9.4 filter-codec-asn1 project depends on ApacheDS' 0.9.5.1 
shared-asn1.  ApacheDS 1.0-C4 depends on 0.9.5.2 of the shared-asn1 and 
on MINA 0.9.4.  Now via transitive dependencies ApacheDS will have a 
dependency on both shared-asn1 versions 0.9.5.1 and 0.9.5.2.  Maven will 
pick the higher revision but unforseen problems can result.

To solve this problem we would like to release MINA so the 
filter-codec-asn1 module depends on shared-asn1 version 0.9.5.2 instead 
of 0.9.5.1.

Besides this, MINA has had several enhancements that we probably want to 
get out the door.

[ ] +1 release MINA 0.9.5
[ ] +/-0 abstain
[ ] -1 do not release MINA 0.9.5

I'll start another thread on possible long term solutions to fixing this 
dependency problem for good.

Thanks,
Alex


Mime
View raw message