directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSERVER-750) update commons-lang from 2.0 to 2.1
Date Mon, 25 Sep 2006 12:44:51 GMT
    [ http://issues.apache.org/jira/browse/DIRSERVER-750?page=comments#action_12437540 ] 
            
Emmanuel Lecharny commented on DIRSERVER-750:
---------------------------------------------

I confirm that commons-lang is not used in shared-ldap. It can be removed.

We can also bump up to 2.1, it's not a big deal.

Pom.xml are inherited, so you may have a dependecy declared on a upper level. In this case,
it's something different. Apacheds depend on shared, which depends on commons-lang, this is
why you have this dependencies. Yes, it's transitive.

It would be cool to switch to 2.1 before the 1.0 code freeze ...

wdyt ?

> update commons-lang from 2.0 to 2.1
> -----------------------------------
>
>                 Key: DIRSERVER-750
>                 URL: http://issues.apache.org/jira/browse/DIRSERVER-750
>             Project: Directory ApacheDS
>          Issue Type: Improvement
>    Affects Versions: 1.0-RC4
>            Reporter: Bastiaan Bakker
>            Priority: Minor
>
> ApacheDS currently uses jakarta commons-lang 2.0, which is over three years old and incompatible
with JDK1.5 (enum keyword conflict). comons-lang-2.1 (the latest released version) is backwards
compatible with 2.0 (with one exception that doesn't affect ApacheDS) and contains several
bugfixes and improvements. It's also required by spring-ldap, a package that can be useful
in partition backend code. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message