directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Henne (JIRA) <j...@apache.org>
Subject [jira] Updated: (DIRSERVER-693) Can't connect with JXplorer
Date Wed, 02 Aug 2006 12:17:14 GMT
     [ http://issues.apache.org/jira/browse/DIRSERVER-693?page=all ]

Jörg Henne updated DIRSERVER-693:
---------------------------------

    Attachment: fix-for-jxplorer-problem.patch

Ok, so I found some time to look into this problem. It seems like the optimized version did
no longer supply the "subschemasubentry" attribute to JXplorer when being asked for it. This
was due to the DefaultPartitionNexus only returning results when being asked for "*", "1.1"
or "+" but not when being asked for specific attributes.

The attached patch fixes the problem. However, I don't really understand the implications
of it. Furthermore, it is likely to cause deoptimization ;-)

> Can't connect with JXplorer
> ---------------------------
>
>                 Key: DIRSERVER-693
>                 URL: http://issues.apache.org/jira/browse/DIRSERVER-693
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: core
>    Affects Versions: pre-1.0
>            Reporter: Jörg Henne
>         Attachments: after-fix.log, connect-via-JXplorer.txt, fix-for-jxplorer-problem.patch,
fix-toString.patch
>
>
> Connecting with JXplorer leads to the NPE in LdapDN as I reported on the list earlier.
Please see the complete log.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message