directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: Logging configuration issue with WNT service on Wintel box (1.0rc3)
Date Tue, 11 Jul 2006 03:18:00 GMT
Alain Pannetier wrote:
> Dear all,
> 
> I've just started using ApacheDS today and have little question for
> you committers if you can spare a minute for me....
> When I download the source from the ASF repository trunk and run under
> debug with Eclipse I can set up my log4j.properties to my own liking
> and follow things up pretty easily. Great.
> 
> When I use the console's (%home%\bin\apachedsw.exe) "logging"
> configuration tab, the only thing I ever get is the banner whatever
> the settings I tried.  My settings are read (changing the prefix is
> honoured) but logging levels such as DEBUG and INFO are not taken into
> account.
> 
> Am I missing something here ?
> I've even tried to add -Dlog4j.configuration in the vm configuration
> tab to force my own log4j config. To no avail.

Hmmm sounds like you're on Windows?  You must be looking at the "vm 
configuration tab" in the service configuration manager.  Yeah I've seen 
this issue before re: logging getting messed up on windows.

I've been staying away from w$ lately.  I think this is a bug tho.  Best 
thing for you to do is put it into JIRA.  I cannot guarrantee getting to 
it very quickly unfortunately :(.  Perhaps someone else is interested.

I'll try to sneak it into RC4 since it's pretty important to have 
logging.  You might want to mark it as critical and please include your 
environment information in your bug report.

Alex


Mime
View raw message