directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trustin Lee" <trus...@gmail.com>
Subject Re: ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)
Date Sun, 04 Jun 2006 07:54:05 GMT
I am sorry for sending this message to dev@directory.  Please ignore it and
reply to the message sent to mina-dev@directory if you're interested.

Apologies,
Trustin

On 6/4/06, Trustin Lee <trustin@gmail.com> wrote:
>
> On 6/3/06, peter royal <proyal@apache.org> wrote:
> >
> > On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
> > > * Renamed ReferenceCountingIoFilterWrapper to
> > > ReferenceCountingIoFilter
> >
> > Do we not want to call it a *Wrapper or *Decorator to indicate that
> > it is a filter that will wrap another filter? I've always been in
> > favor of doing that to make the usage of a class clear from its name...
>
>
> Did we discussed about this naming scheme before?  Please blame my brain
> if so. :)
>
> I just thought that it is OK to omit the name of the pattern because we
> have JavaDoc that can explain what it does in one sentence.  It is because
> using the class means that we know what it does.  From the readibiliy
> viewpoint, we can easily guess that it's a wrapper or a decorator because
> there's another filter as a constructor parameter.  So I think it's fine to
> omit Wrapper or Decorator in class names.
>
> But this is only my opinion.  Let's discuss enough to get to the
> concensus.
>
> Thanks for pointing out,
> Trustin
>

Trustin
-- 
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6

Mime
View raw message