directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: support for LDAPv2 queries
Date Tue, 06 Jun 2006 13:46:59 GMT
niroshan hewakoparage wrote:

>Hi, 
>    Is it possible to configure ApacheDS to support LDAPv2 queries? At the moment i am
getting the following exception with LDAPv2 queries, LDAPV3 woreks file.
> 
>   If configuration is not possible is there a way to achive this? I only need to accept
the LDAPv2 queries and direct it to a custom partition which will process the query with another
LDAP server.(Custom partition acts like a LDAP proxy ).
> 
>   [11:32:42,027] ERROR [org.apache.directory.shared.ldap.codec.bind.BindRequestGrammar]
- The version 2 is invalid : it must be 3
> [11:32:42,029] ERROR [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/10.6.13.70:50029] EXCEPTION:
> org.apache.mina.filter.codec.ProtocolDecoderException: org.apache.directory.shared.ldap.message.MessageException:
decoder failture: Ldap Version 2 is not supported (Hexdump: 04 26 63 6E 3D 72 6F 6F 74 2C
64 63 3D 70 6F 63 6B 65 74 6E 65 74 2C 64 63 3D 74 65 6C 73 74 72 61 2C 64 63 3D 6E 65 74
80 09 63 34 6D 33 6C 65 75 63 68)
>     at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:68)
>     at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(AbstractIoFilterChain.java:494)
>     at org.apache.mina.common.support.AbstractIoFilterChain.access$1000(AbstractIoFilterChain.java:52)
>     at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceived(AbstractIoFilterChain.java:761)
>     at org.apache.mina.filter.ThreadPoolFilter.processEvent(ThreadPoolFilter.java:665)
>     at org.apache.mina.filter.ThreadPoolFilter$Worker.processEvents(ThreadPoolFilter.java:421)
>     at org.apache.mina.filter.ThreadPoolFilter$Worker.run(ThreadPoolFilter.java:376)
> Caused by: org.apache.directory.shared.ldap.message.MessageException: decoder failture:
Ldap Version 2 is not supported
>     at org.apache.directory.shared.ldap.message.MessageDecoder.decode(MessageDecoder.java:210)
>     at org.apache.mina.filter.codec.asn1.Asn1CodecDecoder.decode(Asn1CodecDecoder.java:37)
>     at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:56)
>     ... 6 more
> 
>

Yeah sorry as Emmanuel stated we do not support LDAPv2 specific filters.

Alex


Mime
View raw message