directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Yang <jimy...@safehaus.org>
Subject Re: RC1 on OS X 10.4
Date Fri, 28 Apr 2006 15:31:49 GMT
Steven,

This is a known problem in Mac OS X. We're still figuring out the  
cause. Alex can you confirm this ?

Jim

On Apr 28, 2006, at 10:20 AM, Steven_Carmody@brown.edu wrote:

> I've installed RC1 on my desktop OS X 10.4 system. I've got the  
> firewall turned off. It installed easily, and I can see it  
> listening for connections (on port 10389). However, all attempts to  
> connect to it result in the connection being closed immediately....  
> (eg when I'm using a tool such as ldapbrowser)
>
> Here's a sample from the console:
>
> stc:/Users/stc root# lsof -n -i -P
> COMMAND     PID  USER   FD   TYPE     DEVICE SIZE/OFF   NODE NAME
>
> apacheds  12847  root    7u  IPv6 0x02f1d658      0t0    TCP [::1]: 
> 59836->[::1]:59835 (TIME_WAIT)
> apacheds  12847  root   54u  IPv6 0x02f1d490      0t0    TCP *: 
> 10389 (LISTEN)
> apacheds  12847  root   55u  IPv6 0x02f1d820      0t0    TCP [:: 
> 127.0.0.1]:30003 (LISTEN)
>
> stc:/Users/stc root# cd /Users/stc/Progs/ApacheDS/apacheds-1.0-RC1
> stc:/Users/stc/Progs/ApacheDS/apacheds-1.0-RC1 root# grep 10389 *
> stc:/Users/stc/Progs/ApacheDS/apacheds-1.0-RC1 root# grep 10389 */*
> conf/server.xml:    <property name="ldapPort"><value>10389</value></

> property>
>
> stc:/Users/stc root# telnet localhost 10389
> Trying ::1...
> Connected to localhost.
> Escape character is '^]'.
> Connection closed by foreign host.
>
> Any thoughts or suggestions? Thanks in advance!


Mime
View raw message