directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: Shall we go JDK 1.5 in 1.1 branch
Date Tue, 07 Mar 2006 20:17:33 GMT
Norbet Reilly a écrit :

>Thanks for the update on IBM's plans.
>
>Are you certain that WAS 6 is delivered with JDK1.5, that wasn't my
>expectation and a quick google showed up some people using WAS 6 and
>JDK1.4. Looking at
>http://www-306.ibm.com/software/webservers/appserv/was/features/ it
>seems it supports J2EE 1.4 (which Sun says needs JDK 1.5) but only JDK
>1.4, so presumably they're using some additional back-ported JDK1.5
>libraries but only the JDK1.4 JVM.
>
>Anyway, I know websphere support isn't most probably a pivotal issue
>for the AD development community, but I just trying to point out that
>mandating JDK1.5 at this point may cut you off from some otherwise
>keen customers - like me ;-)
>
>  
>
Sorry about it, I've anticipated a little bit about the move of IBM 
toward JDK 1.5 :), Yeah, Websphere 6 will use 1.4.2, not 1.5 (we will 
have to wait for 6.1, for sure, or 7.0, which is in diaper)

My bad !

 From my point of view, I really don't care if we stick to 1.4. The only 
thing I miss is Enum. But mina has some needs (mainly SSL) that could 
lead it to produce two versions : one for 1.4 and another for 1.5.

At this point, it may be a little bit premature to decide if we have to 
switch from 1.4 to 1.5 in ADS 1.1. We have a lot of time ! ADS 1.0 is 
not even out, we still have to walk the line through 1.0-RC2, 1.0-RC3 
etc... So there is no rush.

As usual, every six months, this question will be raised and this is a 
*good* thing : real users will give their position, and we can think 
about the real consequences of this switch basing our decision on real 
cases, not just opinions :)

Call it democracy ...

Emmanuel Lécharny

Mime
View raw message