directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Blanchard (JIRA)" <j...@apache.org>
Subject [jira] Created: (DIRSERVER-591) Putting some chars like "é" in common name with JXPlorer or my client code creates problems
Date Fri, 10 Mar 2006 16:06:41 GMT
Putting some chars like "é" in common name with JXPlorer or my client code creates problems
-------------------------------------------------------------------------------------------

         Key: DIRSERVER-591
         URL: http://issues.apache.org/jira/browse/DIRSERVER-591
     Project: Directory ApacheDS
        Type: Bug
    Versions: 1.0-RC1    
 Environment: Win XP SP2
JRE 1.5.0_04
ApacheDS RC1.0
    Reporter: Tony Blanchard


It seems the apacheds database does not like "é" chars. 
I even think trying to destroy such entries containing such chars lead to database severe
corruption but I have no real and systematic clue yet.
To reproduce, simply try to put a group with a "é" char in the cn attribute with JXplorer.
Now, try to modify it. Exception araise.
Now, in my client code, I see SearchResult returned with bad results in getName() or getNameInNameSpace().
It seems it returns a string  with " " replaced by "%20" and "é" char replaced with a value
like /ufffd or something like this.
Nevertheless, if I retrieve the attributes from the SearchResult I get the correct "cn" value
with a correct "é" char in it


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message