directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trustin Lee" <trus...@gmail.com>
Subject Re: [RELEASE][ApacheDS] Problems due to recent bug fixes
Date Mon, 20 Feb 2006 13:58:02 GMT
On 2/20/06, Alex Karasulu <aok123@bellsouth.net> wrote:
>
> We have some issues with the RC1 release which is pretty much my fault.
> We fixed some last minute bugs and pushed the shared libs up a notch
> from version 0.9.4.  Both MINA and ApacheDS depend on these libs but
> different versions now.  Here's the situation in a nut shell.
>
> (=> means deps on)
>
> ApacheDS => MINA 0.9.1 ASN1 Codec => Shared ASN1 0.9.4
> ApacheDS => Shared ASN1 0.9.5-SNAPSHOT
> ApacheDS => Shared LDAP 0.9.5-SNAPSHOT


I think Maven should provide a way to specify that ASN1 0.9.5 is just a
minor fix against 0.9.4 so ApacheDS can simply specify the dependency on
shared-asn1 0.9.5 and MINA's dependency on 0.9.4 is ignored.  Is there any
way for now, Brett?  I thought this is what already is being done actually.

Basically we're going to need to vote all over again.  This time perhaps
> we can vote on a simultaneous release of ApacheDS and MINA together.
> I'll tidy everything up over the next few days and launch another vote.
> I apologize for the inconvenience.  I'll do all the heavy lifting to
> correct this problem immediately.


I made the ApacheDS in the trunk compile OK with MINA 0.9.2-SNAPSHOT today.
I hope this works. :)

Trustin
--
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6

Mime
View raw message