directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: mvn eclipse:eclipe pb
Date Sun, 26 Feb 2006 00:59:21 GMT
Ersin Er wrote:

>Well, you're right. There is a problem. Here:
>
>The version of apacheds-server-main is 1.1.0-SNAPSHOT as it's
>inheriting from its parent:
>
><project>
>  <modelVersion>4.0.0</modelVersion>
>  <parent>
>    <groupId>org.apache.directory.server</groupId>
>    <artifactId>build</artifactId>
>    <version>1.1.0-SNAPSHOT</version>
>  </parent>
>  <artifactId>apacheds-server-main</artifactId>
>  <name>ApacheDS Server Main</name>
>  ...
>
>It specifies daemon-bootstrappers as a dependency with the following lines:
>
><dependency>
>      <groupId>org.apache.directory.daemon</groupId>
>      <artifactId>daemon-bootstrappers</artifactId>
>      <version>${pom.version}</version>
></dependency>
>
>So, version 1.1.0-SNAPSHOT of daemon-bootstrappers is expected.
>However there is no such artifact. Because it's version is 1.0-RC1 as
>written in its pom:
>
><project>
>  <modelVersion>4.0.0</modelVersion>
>  <parent>
>    <groupId>org.apache.directory.daemon</groupId>
>    <artifactId>build</artifactId>
>    <version>1.0-RC1</version>
>  </parent>
>  <artifactId>daemon-bootstrappers</artifactId>
>  <name>Apache Directory Daemon Bootstrappers</name>
>
>This should be fixed urgently.
>
>The man's responsible for one week doco and unit test writing, hehe.
>
>  
>

That would be me.  :(.  I told you I would mess up tomorrow yesterday 
didn't I.  Ok I will start on doco and tests for the next week no code.

Alex


Mime
View raw message