directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Alberto Fernandez" <jalbe...@cellectivity.com>
Subject RE: Naming conventions for artifactIds, groupIds and how this relates to site generation
Date Tue, 24 Jan 2006 12:37:24 GMT
> From: Ersin Er [mailto:ersin.er@gmail.com]
> 
> Hi,
> 
> Which form is better up to you?
> 
> 1)
> <groupId>org.apache.directory.mina</groupId>
> <artifactId>core</artifactId>
> 
> or
> 
> 2)
> <groupId>org.apache.directory.mina</groupId>
> <artifactId>org.apache.directory.mina</artifactId>
> 
> or
> 
> 3)
> <groupId>org.apache.directory.mina</groupId>
> <artifactId>mina-core</artifactId>
> 

This is the only one that makes sense in my opinion. It is short and
informative enough.

> 
> And another point: if we choose, for example the 3rd option, consider
> integration and filter subprojects:
> 
> Which one do you prefer?
> 
> 3.1)
> <groupId>org.apache.directory.mina</groupId>
> 3.1.1) <artifactId>mina-netty-codec-filter</artifactId>
> or
> 3.1.2) <artifactId>mina-filter-codec-netty</artifactId>
> 
> or
> 
> 3.2)
> <groupId>org.apache.directory.mina.filter.codec</groupId>
> <artifactId>mina-netty-codec-filter</artifactId>
> 
> or
> 
> 3.3)
> <groupId>org.apache.directory.mina.filter.codec</groupId>
> <artifactId>netty</artifactId> (which mimics 3.1.2 which is strict
> package-class like scheme)
> 

None of them sound right. I do not think you need to say that is a
codec-filter, you just need to say it is a bridge between mina and
netty. The details of the implementation do not need to be transparent
on the name of the artefact.

So something like:
 <artifactId>mina-netty</artifactId>

Should be good enough.

Jose Alberto

Mime
View raw message