directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: [site] Moving to m2
Date Sat, 21 Jan 2006 17:20:34 GMT
I don't experience the problem on JDK 1.5. What version are you using?

- Brett

On 1/21/06, Ersin Er <ersin.er@gmail.com> wrote:
> One of our three subprojects ApacheDS's site is causing problems while
> building. The problem is same again:
>
> [INFO] Trace
> java.lang.NullPointerException
>         at org.apache.maven.doxia.site.decoration.inheritance.DefaultDecorationModelInheritanceAssembler.getParentPrefix(DefaultDecorationModelInheritanceAssembler.java:340)
>         at org.apache.maven.doxia.site.decoration.inheritance.DefaultDecorationModelInheritanceAssembler.resolvePath(DefaultDecorationModelInheritanceAssembler.java:149)
>
> This is generated when I do a "mvn site" in
> "directory/trunks/apacheds". I use the latest version of the site
> plugin but there still is the problem.
>
> Any ideas?
>
> On 1/21/06, Ersin Er <ersin.er@gmail.com> wrote:
> > The main site and mina site is build and deployed successfully at:
> >
> > http://directory.apache.org/newsite
> >
> > Mina site does not conform to m2 conventions well but it works for now.
> >
> > The main site needs content and structure update. As Alex requested,
> > we'll have only three project categories: ApacheDS, Naming and MINA.
> > Other subproject documents will probably go under ApacheDS or will be
> > deleted if no longer necessary.
> >
> > For the project information part we can use maven generated style or
> > custom manual style. In other words, for example, we can have a
> > svn.xml to describe svn stuff (as we currently have) or we can make
> > maven generate it for us. The former was already setup but needs
> > custum content update. Now I've also made maven generate them for us.
> > For example:
> >
> > http://directory.apache.org/newsite/svn.html
> > vs.
> > http://directory.apache.org/newsite/source-repository.html
> >
> > We need to choose one. The former is custom and may be more verbose
> > but needs maintanance. The latter is auto generated but may not be
> > very user friendly.
> >
> > On 1/21/06, Ersin Er <ersin.er@gmail.com> wrote:
> > > Ok, thanks. It seems to work with the latest version of the plugin.
> > >
> > > On 1/20/06, Brett Porter <brett.porter@gmail.com> wrote:
> > > > This was a bug in SVN at one point. I've tested this with the latest
> > > > release (2.0-beta-4) of the site plugin, and it works, as does the
> > > > current SVN version.
> > > >
> > > > - Brett
> > > >
> > > > On 1/20/06, Ersin Er <ersin.er@gmail.com> wrote:
> > > > > The main site migration goes promising but other projects' sites
are
> > > > > problematic. I have the same problem I mentioned in the other thread
> > > > > which is:
> > > > >
> > > > > ...
> > > > > [INFO] Trace
> > > > > java.lang.NullPointerException
> > > > >         at org.apache.maven.doxia.site.decoration.inheritance.DefaultDecorationModelInheritanceAssembler.getParentPrefix(DefaultDecorationModelInheritanceAssembler.java:340)
> > > > >         at org.apache.maven.doxia.site.decoration.inheritance.DefaultDecorationModelInheritanceAssembler.resolvePath(DefaultDecorationModelInheritanceAssembler.java:149)
> > > > > ...
> > > > >
> > > > > I get this while I try to mvn site for asn1 project. I think I have
> > > > > done required changes for m2 but it does not build..
> > > > >
> > > > > On 1/20/06, Ersin Er <ersin.er@gmail.com> wrote:
> > > > > > Hi again,
> > > > > >
> > > > > > The new site looks more like the previous now. I fixed some
problems
> > > > > > which are both because of me and because of some new m2 conventions.
I
> > > > > > still get the same error I mentioned below.
> > > > > >
> > > > > > On 1/20/06, Ersin Er <ersin.er@gmail.com> wrote:
> > > > > > > Sorry for opening a new thread about the same subject but
I did not
> > > > > > > want to confuse you with the old discussion. Now I'm trying
to migrate
> > > > > > > old site subproject to m2. The build (mvn site) again fails
but some
> > > > > > > doco are generated. The most obvious problem is that index.html
is not
> > > > > > > being generated. I get the following error during site
generation:
> > > > > > >
> > > > > > > [ERROR] VM #displayTree: error : too few arguments to macro.
Wanted 2 got 0
> > > > > > > [ERROR] VM #menuItem: error : too few arguments to macro.
Wanted 1 got 0
> > > > > > >
> > > > > > > However the generating completes *successfully*. And the
generated site is here:
> > > > > > >
> > > > > > > http://directory.apache.org/newsite/
> > > > > > >
> > > > > > > Does not seem very good now :-D
> > > > > > >
> > > > > > > We'll fix it of course.
> > > > > > >
> > > > > > > Any help is appreciated.
> > > > > > >
> > > > > > > Cheers,
> > > > > > >
> > > > > > > --
> > > > > > > Ersin
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Ersin
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Ersin
> > > > >
> > > >
> > >
> > >
> > > --
> > > Ersin
> > >
> >
> >
> > --
> > Ersin
> >
>
>
> --
> Ersin
>

Mime
View raw message