directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: Naming conventions for artifactIds, groupIds and how this relates to site generation
Date Mon, 23 Jan 2006 02:26:23 GMT
Ersin Er wrote:

>Hi all,
>
>We currently use artifactIds like package names. For example we have:
>
><artifactId>org.apache.ldap.server.core</artifactId>
>  
>
Yeah this was an experiment that just did not work out.  I'm ready to 
back out of this. 

>(and we have no groupId for this definition, so it's inherited from
>parent which is org.apache.directory.server.)
>
>However I think we should have:
>
><groupId>org.apache.ldap.server</groupId>
><artifactId>core</artifactId>
>
>This allows a better repository structure which looks like the
>standard Java library layout where groupIds are like package names and
>artifactIds are like class names.
>  
>
Right plus the fact that the groupId is a package prevents collisions 
now with the artifactId.  This is something we did not consider with 
this present scheme.

>Another income using this approach is that it allows finer site
>generation. m2 uses artifactIds for generating subproject directories.
>  
>
Ooooooohh ok that certainly clarifies what we must do.  Everything is 
getting to be somewhat messy now with all these artifacts having their 
id's set to the package name.  It's also very redundant with the groupId 
also having the same package name.  It's out of control.

...

>So it may be best to use shortest explanotory name possible like:
>
>directory-asn1
>mina-core
>common-ldap
>apacheds-plugin or apacheds-maven-plugin (not maven-directory-plugin
>(which is an internal convention of maven project I think) ?)
>protocol-kerberos (not apacheds-protocol-kerberos ?)
>
>It this is still not explanatory then I offer more. We may keep
>package name artifactIds which causes other problems.
>
>And also maven conventions favor the final approach.
>
>As the final note consider that eclipse project generated by maven
>take the name from artifactIds. (However IMO they should have taken
>the name field in the pom.)
>
>And I still see chance for the first scheme I offered (single level
>artifactId like core), please also consider that one.
>
>WDYT?
>
>And I think Brett may have good advices for us while he knows the
>conventions and incomes best.
>  
>

I agree with reverting to simple short artifactIds with the groupId 
being set to a package.


+1 Please Brett let us know.  I think you, Brett, may have warned me a 
few times about this approach being not too good where maven is 
concerned.  I really should have listened more rather than exprimenting :).

Alex


Mime
View raw message