directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: LDAP 0.9.3 . Modify attribute fails with exception
Date Sun, 15 Jan 2006 23:53:08 GMT

>> Ok, seems to be related to the schema handling. I will try to 
>> reproduce this on my server .
>
>
> I don't think this is an an error.  He's using an undefined attribute: 
> activeFlag.  Since 0.9 we have added some minimal schema checks.

hmmm... What about the fact that the entry was correctly created with 
this not existing attribute? Isn't it weird that the server accept a 
creation but not a modification in this case?

>
>>> Thanks
>>> Somashish
>>>
>>> PS I haven't logged any bug till now as suggested by you because I 
>>> think the
>>> problem is most likely to be an issue at my end. Let me know if I 
>>> still need
>>> to go ahead and file a bug.
>>
>>
> Guys, I don't think there is a need for a JIRA issue on this one.  If 
> adding a the attributeType with a schema does not resolve this issue 
> then yeah I think we should file an issue.


For the very same reason I exposed in my previous comment, if you can 
create an entry with a non existing attribute, but you can't modify it 
because you have a schema check, that's sound to be something we want to 
reproduce and eventualy add to a regression test. This is why I asked 
for a Jira filling. But if this is just a configuration mistake, of 
course, jira is not the way to go.

I apologize if I induced some "noise" in Jira.

-- Emmanuel L├ęcharny


Mime
View raw message