directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: [apacheds] LDAPS status
Date Thu, 12 Jan 2006 17:33:48 GMT
Trustin Lee wrote:

> Hi all,
>
> I separated the code which depends on JDK 1.5 from 
> ServerContextFactory so it can run without a problem when ApacheDS 
> runs on JDK 1.4.  I used dynamic class loading to resolve this issue.
>
> But for now, it only compiles on JDK 1.5, and server-unit test will 
> pass only on JDK 1.5, too.  I wanted to disable compilation of 
> SSL-related classes and LdapsTest, but I couldn't figure out how to do 
> it yet.
>
> I saw Alex did the similar thing in mina-build/pom.xml, but what I 
> want to do is just to exclude a few classes, not the whole module.

You can do something similar to the jdk14 and jdk15 profiles but instead 
of excluding a module in the build you simply have a different plugin 
section for surefire that excludes the respective 1.5 tests. 

I do recommend the isolation of the JDK 1.5 specific SSL code in 
apacheds (core) into its own module though.  This way the 1.4 build can 
progress without it being included and the server can run on 1.4 as 
well.  Like we do with MINA today.  If you have any problems let me know 
I can bang it out for you.

Alex
 

Mime
View raw message