directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alessandro Torrisi (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRMINA-152) SO_REUSEADDR in 0.9 is gone ?
Date Tue, 27 Dec 2005 08:45:31 GMT
    [ http://issues.apache.org/jira/browse/DIRMINA-152?page=comments#action_12361257 ] 

Alessandro Torrisi commented on DIRMINA-152:
--------------------------------------------

java.net.BindException: Address already in use
at sun.nio.ch.Net.bind(Native Method)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
at org.apache.mina.transport.socket.nio.support.SocketAcceptorDelegate.registerNew(SocketAcceptorDelegate.java:366)
at org.apache.mina.transport.socket.nio.support.SocketAcceptorDelegate.access$2(SocketAcceptorDelegate.java:330)
at org.apache.mina.transport.socket.nio.support.SocketAcceptorDelegate$Worker.run(SocketAcceptorDelegate.java:231)

I've got this problem ONLY UNDER UNIX (Mac Os X and Linux), while Windows Mina behaviour is
correct, it shutdowns cleanly without any problem. 
I experienced this problem with Mina 0.9.0 and Mina 0.91 snapshots.

> SO_REUSEADDR in 0.9 is gone ?
> -----------------------------
>
>          Key: DIRMINA-152
>          URL: http://issues.apache.org/jira/browse/DIRMINA-152
>      Project: Directory MINA
>         Type: Bug
>     Versions: 0.9
>  Environment: in MINA 0.9 after a violent JVM shutdown (like Eclipse stop button) the
TCP port aren't unbinded
>     Reporter: Julien Vermillard

>
> look like 0.9 is not configuring TCP port for reusing

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message