directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: [apacheds] SSL support and Java 5
Date Thu, 29 Dec 2005 14:17:37 GMT
Stefan Zoerner wrote:

> Hi Trustin!
>
> Trustin Lee wrote:
>
>> Hi all.
>>
>> I'm adding LDAPS support in apacheds-server.  It is implemented in 
>> ServerContextFactory.startLDAPS(...).  I used MINA SSLFilter and 
>> javax.net.ssl package for it.  This means Java 5 is mandatory to 
>> start up ApacheDS LDAPS.  I'm not sure ApacheDS will run in JDK 1.4, 
>> but I guess we need to load the classes dynamically to make it run in 
>> JDK 1.4.
>>
>> Do we need SSL in JDK 1.4?  ...
>
>
> For a user who runs ApacheDS standalone as an LDAP server it is 
> somewhat easy to select the underlying JRE. Java 5 would be no problem 
> from my point of view. Almost all OS already have an appropriate JRE 
> available (not sure about OS/2, z/OS and other even more exotic stuff).
>
> But because people like to embed ApacheDS in applications (like 
> Geronimo or Jetspeed-2 do), and as long as these application should 
> run with older Java versions as well, I think it is quite important to 
> support at least base functionality with JDK 1.4. Does ldaps/SSL 
> belong to this base? I am not sure, but I believe it does not.

Yes I agree. Let's make sure the server still runs on 1.4 for embedding 
in which case the user will not be able to use LDAPS.  Also thanks 
Trustin for working this in the sandbox for now.  I will start migrating 
the other projects today for m2 configuration.

Alex


Mime
View raw message