> SSLFilter depends on Java 5 SSLEngine.  Other parts works fine with Java  1.4. :)
> It would be great if we can support SSL for Java 1.4.
 
Yeah - I haven't looked in to it much, but it seems like SSLEngine is designed for non-blocking use. Dont know if there is anything similar for pre java 5.
 
Whats the long term plan for versioning support? Is it possible that there might still be a pre java 5 official mina distribution (for those of us who are prepared to not use SSL)?
Or should I just pull myself out of the dark-ages and try and upgrade to java 5?
 
Cheers,
 
Dave

From: Trustin Lee [mailto:trustin@gmail.com]
Sent: 02 November 2005 12:31
To: Apache Directory Developers List
Subject: Re: [mina] Trying to build mina from trunk...

2005/11/2, Irving, Dave <dave.irving@logicacmg.com>:
Worked brilliantly with Maven 1 - thank you.
Seems we need java 5 now though..?
Interesting.... :o)

SSLFilter depends on Java 5 SSLEngine.  Other parts works fine with Java  1.4. :)
It would be great if we can support SSL for Java 1.4.

Cheers,
Trustin
--
what we call human nature is actually human habit
--
http://gleamynode.net/

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.