directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: [mina] m2 issues
Date Sun, 06 Nov 2005 21:56:32 GMT
That's a plugin. There's an issue in the conversion process currently
that it doesn't exclude maven 1 plugin dependencies like it should.

You can add something like this:

<dependency>
  ...
  <artifactId>mina</artifactId>
  <exclusions>
    <exclusion>
      <groupId>emma</groupId>
      <artifactId>emma</artifactId>
    </exclusion>
  </exclusions>
</dependency>

- Brett

On 11/7/05, Michal Slocinski <mslocins@gmail.com> wrote:
> Hi,
>
> I've just tried to use maven 2 for my project using mina however there
> are some issues with it. Because of transitive dependencies, m2 tries
> to download emma 2.0.latest (MINA's dependency) from repo1.apache.org.
> However, such version simply doesn't exist. Question is if this
> dependency shouldn't has <scope>test</scope> in MINA's pom.xml (same
> as junit shoud has)? If not - do you youse any additional repository
> except standard one to download emma 2.0.latest? Or I'm missing
> something when using m2? :-)
> --
> best regards,
> Michal
>

Mime
View raw message