directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trustin Lee <trus...@gmail.com>
Subject Re: Trunk Build Troubles
Date Sat, 12 Nov 2005 04:24:27 GMT
This is strange again. Are you building MINA with JDK 1.4.x? You'll need JDK
1.5.x to build MINA. But this doesn't necessarilly mean that you need Java 5
to run MINA. It runs OK with 1.4. Please refer to the FAQ about this.

Trustin

2005/11/12, Amit Kumar <amitku@uiuc.edu>:
>
> Thanks a bunch, you are most helpful.
>
> No, I am not behind a hardware/software firewall.
> %ipfw list
> 02000 allow ip from any to any
>
> This is weird I was able to download the jar files and put them in the
> ~$HOME/.maven/.... but now I get this message
>
> %maven jar
>
> .....
> java:prepare-filesystem:
>
> java:compile:
> [echo] Compiling to /contents/workspace/mina/trunk/target/classes
>
> BUILD FAILED
> File...... /Users/amitku/.maven/cache/maven-java-plugin-1.5/plugin.jelly
> Element... ant:available
> Line...... 75
> Column.... 81
> class javax.swing.SwingGraphics cannot access its superinterface
> javax.swing.GraphicsWrapper
> Total time: 37 seconds
> Finished at: Fri Nov 11 21:02:17 CST 2005
>
>
> I am on OSX if that matters. Getting closer it feels...
>
>
> Regards,
> Amit
>
>
>
>
> On Nov 11, 2005, at 8:44 PM, Trustin Lee wrote:
>
> Are you behind a firewall or something like that? I deleted emma from my
> local repository and it retrieved the JAR correctly.
>
> Please try to connect here:
>
> http://cvs.apache.org/repository/emma/jars
>
> and
>
> http://cvs.apache.org/repository/emma/plugins
>
> If the problem continues you can simply copy the two jars which were
> failed to download to your local maven repository. It is located at
> $HOME/.maven/repository/
>
> HTH,
> Trustin
>
> 2005/11/12, Amit Kumar <amitku@uiuc.edu>:
> >
> >
> > % cat project.properties | grep maven.repo.remote
> > maven.repo.remote=http://cvs.apache.org/repository ,
> > http://www.ibiblio.org/maven/, http://mirrors.sunsite.dk/maven
> >
> >
> > Same error...
> >
> > Attempting to download emma-2.0.latest.jar.
> > WARNING: Failed to download emma-2.0.latest.jar .
> > Attempting to download maven-emma-plugin-0.4.jar.
> > WARNING: Failed to download maven-emma-plugin-0.4.jar.
> > The build cannot continue because of the following unsatisfied
> > dependencies:
> >
> > emma-2.0.latest.jar (try downloading from http://emma.sourceforge.net/)
> > maven-emma-plugin-0.4.jar (try downloading from
> > http://emma.sourceforge.net/)
> >
> > Any other ideas ? maven is a black box to me, I am still with ant...
> >
>
> --
> what we call human nature is actually human habit
> --
> http://gleamynode.net/
>
>
>


--
what we call human nature is actually human habit
--
http://gleamynode.net/

Mime
View raw message