directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Alberto Fernandez" <jalbe...@cellectivity.com>
Subject [MINA] RE: [jira] Commented: (DIRMINA-2) Traffic control
Date Fri, 28 Oct 2005 16:25:52 GMT

I do not think it is nice to start changing the name of basic classes in
MINA, after all there is plenty of code using it (even if it is 0.8).

These are really different concepts that you are referring here, no?

Jose Alberto

> -----Original Message-----
> From: Trustin Lee (JIRA) [mailto:jira@apache.org]
> Sent: 28 October 2005 16:25
> To: dev@directory.apache.org
> Subject: [jira] Commented: (DIRMINA-2) Traffic control
> 
>     [ http://issues.apache.org/jira/browse/DIRMINA-
> 2?page=comments#action_12356212 ]
> 
> Trustin Lee commented on DIRMINA-2:
> -----------------------------------
> 
> We can rename IdleStatus to IoType and reuse it like this:
> * IoSession.suspend( IoType )
> * IoSession.resume( IoType )
> 
> > Traffic control
> > ---------------
> >
> >          Key: DIRMINA-2
> >          URL: http://issues.apache.org/jira/browse/DIRMINA-2
> >      Project: Directory MINA
> >         Type: New Feature
> >     Versions: 0.7, 0.8
> >     Reporter: Trustin Lee
> >     Assignee: Trustin Lee
> >     Priority: Minor
> >      Fix For: 0.9.1
> 
> >
> > IoSession should have some traffic control methods to throttle
traffic.
> >  * IoSession.suspendRead()
> >  * IoSession.resumeRead()
> >  * IoSession.suspendWrite()
> >  * IoSession.resumeWrite()
> 
> --
> This message is automatically generated by JIRA.
> -
> If you think it was sent incorrectly contact one of the
administrators:
>    http://issues.apache.org/jira/secure/Administrators.jspa
> -
> For more information on JIRA, see:
>    http://www.atlassian.com/software/jira


Mime
View raw message