directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Irving, Dave" <dave.irv...@logicacmg.com>
Subject RE: [mina] Very rare NIO selector problem.
Date Mon, 31 Oct 2005 14:58:56 GMT
I seem to remember there being a problem with Selector#select not
blocking back in previous JDK versions - but AFAIK these were later
fixed.
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4850373
 
Probably not related though....

________________________________

From: Trustin Lee [mailto:trustin@gmail.com] 
Sent: 31 October 2005 14:52
To: Apache Directory Developers List
Subject: [mina] Very rare NIO selector problem.


Hi,

I've found a strange issue related with NIO Selector while testing
ConnectorTest; Selector.select() doesn't block at all sometimes.  I'm
using JDK 1.5.0_04.  I can reproduce this about once per 40 minutes.  It
took me a whole day to find out that Selector.select() doesn't block at
all rarely. :(

I think it is OK basically, but I'd like to know why.

Any ideas?

Trustin
-- 
what we call human nature is actually human habit
-- 
http://gleamynode.net/ 


This e-mail and any attachment is for authorised use by the intended recipient(s) only. It
may contain proprietary material, confidential information and/or be subject to legal privilege.
It should not be copied, disclosed to, retained or used by, any other party. If you are not
an intended recipient then please promptly delete this e-mail and any attachment and all copies
and inform the sender. Thank you.

Mime
View raw message