directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Betts <ch...@pegacat.com>
Subject Re: Only 'uid=admin,ou=system' can initiate the first run.
Date Mon, 03 Oct 2005 10:03:24 GMT
Hi Folks,

     I've been trying to get the 0.9.3 version going (I was using 0.9).

     Initially I had the same problem as Stefan, and indeed I still  
can't get it to run using 'default properties'.  However, once I'd  
figured out that 'server.properties' had changed to 'server.xml', and  
got my paths sorted out,  it starts fine.  The problem now is that I  
get an error
'Exception in thread "main" javax.naming.NamingException:  
attributeType w/ OID 1.2.6.1.4.1.18060.1.1.1.3.26 has already been  
registered!
(BoostrapAttributeTypeRegistry.java:88).

     Any ideas?  Have the false starts messed things up somehow?   
This is using the default server.xml I found in svn_head\apacheds 
\trunk\main after doing a full svn update.

     Also, do we have an easy listening 'getting started' guide  
somewhere?  The 'Building and Running the Apache Directory Server'  
web page is good, but could it be expanded and updated a little?   
Maybe we can link it to a wiki page, and that way we could all keep  
it up to date when things change?  (I'd be happy to have the first  
crack at writing such a page, from the perspective of the  
clueless :-) ).

    - Chris



On 22/09/2005, at 11:13 PM, Trustin Lee wrote:

> ApacheDS initializes system context partition at its first run.  It  
> adds entries such as admin user which contains admin password.   
> ApacheDS has to run as an admin at the first time to create an  
> appropriate administrator information.
>
> We can fix this issue by using default admin password.  WDYT?
>
> 2005/9/22, Jérôme Baumgarten <jbaumgarten@gmail.com>:
> Hi,
>
> I just compiled ApacheDS (from SVN) and still get the behaviour
> described by Stefan except that the server immediately stops and it
> always behaves that way, no way to get it up and running.
>
> Regards,
> Jérôme
>
> On 9/22/05, Trustin Lee <trustin@gmail.com> wrote:
> > Hi Stefan,
> >
> > Sorry for the late reply first of all.  I hope you understand me. ;)
> >
> > 2005/8/29, Stefan Zoerner <stefan@labeo.de>:
> > > If I use a current apacheds-main-0.9.2-SNAPSHOT.jar and
> > execute a simple
> > >
> > > java -jar apacheds-main-0.9.2-SNAPSHOT.jar
> > >
> > > in a fresh directory, I get the following exception on the  
> cmdline:
> > >
> > > Exception in thread "main"
> > javax.naming.NoPermissionException : Only
> > > 'uid=admin,ou=system' can initiate the first run.
> > >          at
> > >
> >  
> org.apache.ldap.server.jndi.DefaultContextFactoryService.checkPermissi 
> onToCreateBootstrapEntries(DefaultContextFactoryService.java
> > :578)
> > > ---
> > >
> > > After this message, the server starts and after some time  
> clients are
> > > able to connect. If I stop the server and restart it the same  
> way (it is
> > > not the first run, partition is available on disk), the error  
> does not
> > > occur.
> >
> > I fixed this issue just before. :)
> >
> > Trustin--
> > what we call human nature is actually human habit
> > --
> > http://gleamynode.net/
>
>
>
> -- 
> what we call human nature is actually human habit
> --
> http://gleamynode.net/


Mime
View raw message