directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesper Söderlund <Jesper.Soderl...@smarttrust.com>
Subject RE: Newbe help - startup problems....
Date Thu, 20 Oct 2005 17:35:12 GMT
Not much more success there unfortunatly it complained that alot of classes were missing when
I took the HEAD version in source repository.
 
I did start the 0.9 release successfully and this will probably suffice for me for the time
beeing until the 0.9.X-branch can be made to work for more beginning users.
 
Thanks!
/Jesper

________________________________

From: Stefan Zoerner [mailto:SZOERNER@de.ibm.com] 
Sent: den 20 oktober 2005 17:12
To: Apache Directory Developers List
Subject: Re: Newbe help - startup problems....



Hi Jesper, 

Thanks for your interest in Apache Directory Server! 

I was able to reproduce your error. There may be a better solution, but an easy way to start
it in your situation is to use a configuration file. 
In 0.9.2 configuration was changed to a spring based XML file. You can find an up to date
example file "server.xml" in the subversion of the project here: 

http://svn.apache.org/viewcvs.cgi/directory/apacheds/trunk/main/server.xml 

The current revision does not work with 0.9.2. But you can uses this one, it works fine (at
least the error disappeared): 

http://svn.apache.org/viewcvs.cgi/*checkout*/directory/apacheds/trunk/main/server.xml?rev=240160


You start the server simply like this 

java -jar apacheds-main-0.9.2.jar server.xml 

The XML-file contains interesting parameters for you: 
- username and password of the admin user 
- port on which LDAP is listening (10389 per default) 
- whether anonymous access is allowed (false per default) ... 

Feel free to ask if the problem persists after using this server.xml file (we have to adjust
the documentation anyway). 

I hope that helps + Greetings from Hamburg, 
    Stefan

Mime
View raw message