directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Norbet Reilly <nrh...@gmail.com>
Subject Re: jdk 1.4/1.5 incompatibility problem?
Date Fri, 23 Sep 2005 03:23:36 GMT
I see the same problem with a different file. I have deleted the ldap common
0.9.3 jar from my maven repository, but that didn't help.

directory:generate:


[echo] Compiling to d:\src\reference\apacheds\apacheds\trunk\core/target/cla
sses
[javac] Compiling 400 source files to D:\src\reference\apacheds\apacheds\tru
nk\core\target\classes
D:\src\reference\apacheds\apacheds\trunk\core\src\main\java\org\apache\ldap\serv
er\authz\TupleCache.java:27: cannot access
org.apache.ldap.common.acl.ACIItem
bad class file: C:\Documents and Settings\...\.maven\repository\directory-sh
ared\jars\ldap-common-0.9.3-SNAPSHOT.jar(org/apache/ldap/common/acl/ACIItem.clas
s)
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the
classpa th.
import org.apache.ldap.common.acl.ACIItem;
^
1 error

BUILD FAILED
File...... C:\Documents and Settings\...\.maven\cache\maven-multiproject-plu
gin-1.3.1\plugin.jelly
Element... maven:reactor
Line...... 217
Column.... 9
Unable to obtain goal [multiproject:install-callback] -- C:\Documents and
Settin gs\...\.maven\cache\maven-java-plugin-1.5\plugin.jelly:63:48:<ant:javac>
Co mpile failed; see the compiler error output for details.
Total time: 33 seconds
Finished at: Fri Sep 23 13:21:00 EST 2005

Mime
View raw message