directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Barrett" <Jaco...@attachmatewrq.com>
Subject RE: [ApacheDS] Moving to JDK 5.0
Date Fri, 23 Sep 2005 15:51:55 GMT
> From: Alex Karasulu [mailto:aok123@bellsouth.net] 
> We intend in the next release to move to jdk 5.0 without 
> backward compatability with JDK 1.4.  This was a hard 
> decision to make but some features in jdk 5.0 are required 
> for us to make ApacheDS LDAPv3 compatable.
> 
> Namely we are going to be using jdk 5.0 features for SASL support. 

I assume there are many more factors in this decision, but have you
considered using the original JSR implementation which is 1.4
compatible?  The packages, class names and JavaDocs are from what I can
tell identical.

http://www.worldspot.com/jsr28/

Sorry if I am beating dead horse here.  I just know 1.5 is way out of
the question where I work so I am not looking forward to forking away
from the main trunk of the ApacheDS.  Call me selfish... :)

Mime
View raw message