directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: [ApacheDS] Moving to JDK 5.0
Date Fri, 23 Sep 2005 04:31:04 GMT
+1 for the server. Please consider differently for other consumable
libraries (eg -naming probably should remain 1.3/1.4, I'm not sure
about things like MINA).

Before jumping in, I know this was discussed maybe 6 months ago -
someone might like to dig in the archives and see if there were any
cases against it that still hold.

- Brett

On 9/23/05, Alex Karasulu <aok123@bellsouth.net> wrote:
> Hi all,
>
> We intend in the next release to move to jdk 5.0 without backward
> compatability with JDK 1.4.  This was a hard decision to make but some
> features in jdk 5.0 are required for us to make ApacheDS LDAPv3 compatable.
>
> Namely we are going to be using jdk 5.0 features for SASL support.
>
> We have drawn up a roadmap to reach a 1.0 release for ApacheDS by March
> of 2006.  By that time we suspect the jdk 5.0 to be the standard JDK in
> production.  Here's the roadmap btw:
>
> http://docs.safehaus.org/pages/viewpage.action?pageId=2394
>
> We will move this roadmap into the ASF JIRA as soon as we distill fine
> grained tasks from it.  Please excuse the storm of JIRA issue movements
> that will follow.
>
> All those that want to use ApacheDS with 1.4 should use releases 0.9.2
> and below.  0.9.3 is debatable but 0.9.4 will definately use 5.0
> features and hence will be 1.4 incompatable.
>
> Thanks,
> Alex
>
>

Mime
View raw message