directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Faiz <n...@atlassian.com>
Subject Re: upgrading to nlog4j.1.2.17
Date Wed, 14 Sep 2005 03:39:44 GMT
Hey Ceki,

Ceki Gülcü wrote:
>> dependencies. One of these modules lists ApacheDS as a dependency. The 
>> jar for ApacheDS is holding an unpacked slf4j and log4j distro, (see 
>> attached screenshot).
> 
> What's in the slf4j distro? Is nlog4j.jar included?
> 

It's nlog4j.1.2.14

> 
> Is ApacheDS compiled against nlog4j? If so, could you try replacing 
> log4j with nlog4j and give it a whirl?
> 

Yes, I have compiled ApacheDS against nlog4 (version above). The log4j 
dependencies are not present in ApacheDS. There doesn't seem like much 
point in replacing log4j with nlog4j in the other modules, as the other 
modules *must* stay with log4j. I know that you probably we're 
suggesting this sort of replacement ...

> 
> My guess (needs to be verified) is that when module 4 and ApacheDS are 
> used, classes in nlog4j.jar are used, however with modules 1, 2 and 3, 
> classes in log4j.jar are seen first (since they are "local" or in the 
> closest scope). I'd have to verify this hypothesis. Will report back later.
> 

Yes, I have thought something along those lines also. If it's simply an 
IDE related bug it might not be so serious but it still is a major 
obstacle - it effectively means that each logging statement in module4 
has to be commented out when working in an IDEA.

Thanks for your fast response to this.

Cheers,
Nick

-- 
ATLASSIAN - http://www.atlassian.com/

Confluence - the enterprise wiki - tried it yet?
http://www.atlassian.com/confluence/
--

Mime
View raw message