directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@apache.org>
Subject RE: [ApacheDS] Moving to JDK 5.0
Date Sat, 24 Sep 2005 15:51:27 GMT
Well, that's very valid points.

What about focusing on 1.4 for the 1.0 version, as all the code is
already 1.4 compliant, dealing with this SASL 1.5 issue by backporting
the offending class (something very commonly done in old days when
dealing with 1.1.8 -> 1.2 or 1.2 -> 1.3 java porting), and planning to
use 1.5 for ApacheDS 2.0?

Then we will be able to carry two different versions. The ADS 1.0 will
then be a dead branch, with fixes only.

Wdyt ?

Emmanuel.

On Sat, 2005-09-24 at 10:15 -0400, Noel J. Bergman wrote:
> If we want to be embedded in J2EE applications, we cannot practically
> require anything more than J2SE 1.4.  If ApacheDS were to require JDK 1.5 it
> will effectively preclude many of us from using it in embedded situations.
> 
>     --- Noel
> 
> ---------------------------------------------------------------------------------------
> Wanadoo vous informe que cet  e-mail a ete controle par l'anti-virus mail. 
> Aucun virus connu a ce jour par nos services n'a ete detecte.
> 
> 
> 



Mime
View raw message