directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Zoerner <ste...@labeo.de>
Subject Minumum/recommended J2SE version for Apache DS
Date Mon, 29 Aug 2005 19:01:46 GMT
Hi all!

Currently I finish the ApacheDS paragraph in the 2dn edition of my LDAP 
little German book for Java developers 
(http://www.entwickler.com/buecher/ldap/, 1st edition), and I asked 
myself, which J2SE is minumum for running the server. Due to new IO I 
would guess it is 1.4, and I successfully started the server on that 
version. The Mina Wiki states SSL support uses 1.5 functionality 
(javax.net.ssl.SSLEngine), which would lead to a higher version 
reqirement, if we would support ldaps that way.

What should I tell my readers? Take into account, that the book, once 
printed, can't be changed. So if think JSE 5 will be mandatory in the 
medium term, it is also an option just to say "it needs J(2)SE".

Thanks in advance for a statement here,
     Stefan



Mime
View raw message