directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon.Tem...@saaconsultants.com
Subject Re: Embedding 0.9 Problems
Date Wed, 18 May 2005 16:17:23 GMT





OK

I have removed JBoss from the equation and created a Class with a simple
Main() method.

If I have apacheds-main-0.9.jar on the classpath it works fine.  If I have
the following on the classpath I get the ClassCastException:

  jdbm-0.12.jar
  apacheds-shared-0.9.jar
  apacheds-core-0.9.jar
  kerberos-common-0.4.jar
  jakarta-oro-2.0.8.jar
  jakarta-regexp-1.3.jar
  aspectjrt.jar
  asn1-ber-0.3.jar
  asn1-codec-0.3.jar
  commons-collections-3.0.jar
  kerberos-protocol-0.4.jar
  commons-io-1.0.jar
  antlr-2.7.2.jar
  commons-primitives-20041207.202534.jar
  commons-lang-2.0.jar
  ldap-clients-0.9.jar
  ldap-common-0.9.jar
  mina-0.7.jar
  ldap-protocol-0.9.jar

So it seems to point to the JAR file combination I'm using?

I've tried to ensure I have the correct versions of everything but...

Is there a full list anywhere or does someone have an Eclipse project that
holds references to all the required JARs for 0.9?


TIA

Simon Temple




                                                                           
             Stephane Bailliez                                             
             <sbailliez@apache                                             
             .org>                                                      To 
                                       Apache Directory Developers List    
             18/05/2005 16:13          <dev@directory.apache.org>          
                                                                        cc 
                                                                           
             Please respond to                                     Subject 
             "Apache Directory         Re: Embedding 0.9 Problems          
             Developers List"                                              
             <dev@directory.ap                                             
                 ache.org>                                                 
                                                                           
                                                                           
                                                                           




Simon.Temple@saaconsultants.com wrote:

>
>
>Hi
>
>I'm trying to wrap your server as an mbean for deployment in jBoss.
>
>I've been unable to use apacheds-main-0.9.jar as some of it's embedded
>classes cause classpath and deployment issues with other mbeans so I have
>decided to use apacheds-core-0.9.jar with a full set of its dependant
JARs.
>
>When I start the server using the following code I get the attached
>ClassCastException.
>
>Does anyone have any ideas on what may be wrong?  It's likely to be a
>problem with classpath and/or JAR file combination but just can't spot
>it...
>
>

Can you clarify your deployment structure ?

I smell the dreaded jboss unified class loader issue, so it might be
time to actually to look at isolating applications and disable the java2
delegation model.
As the server is also stuffing your parent classloader with a whole lot
of third parties it is based on, you certainly inherit some libs that do
not help in having a clean environment.



Mime
View raw message