directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject Re: trying to load custom-schema data...
Date Thu, 19 May 2005 19:11:36 GMT
I'm having a problem trying to generate schema from my custom schema.
I added my schema files to the core\src\main\schema folder, and then I
added their names to the end of the maven.ldap.server.schemas line in
the project.properties file.

Now, when I run the maven build, it does this:


\apacheds-0.9-src\apacheds-0.9\core>maven -V directory:genrate
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0.2

build:start:

directory:prepare-filesystem:

directory:generate:
    [echo] Generated schema producer classes for apachedns.schema
    [echo] Generated schema producer classes for autofs.schema
    [echo] Generated schema producer classes for core.schema
    [echo] Generated schema producer classes for cosine.schema
    [echo] Generated schema producer classes for corba.schema
    [echo] Generated schema producer classes for apache.schema
    [echo] Generated schema producer classes for inetorgperson.schema
    [echo] Generated schema producer classes for java.schema
    [echo] Generated schema producer classes for krb5kdc.schema
    [echo] Generated schema producer classes for nis.schema
    [echo] Generated schema producer classes for system.schema
    [echo] Generated schema producer classes for dhcp.schema
    [echo] Generated schema producer classes for samba.schema

BUILD FAILED
File...... C:\Documents and
Settings\ARMBRUST\.maven\cache\maven-directory-plugin-0.9\plugin.jelly
Element... j:useBean
Line...... 59
Column.... 87
java.lang.reflect.InvocationTargetException
Total time: 4 seconds
Finished at: Thu May 19 14:02:29 CDT 2005

My first schema file is attached - is there something wrong with it? 
All of my schema is valid (according to OpenLDAP anyway)

Or maybe I'm just doing something else wrong - any advice would be appreciated.

Thanks, 

Dan

Mime
View raw message