directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject Re: trying to launch with custom schema
Date Fri, 20 May 2005 18:52:59 GMT
After I added the schemas I was missing, it comes down to just these two 
that don't appear to be supported:

caseExactOrderingMatch
integerOrderingMatch


When I comment out the appropriate ORDERING lines from my schema 
(snippits below) then it works fine.

Should I file a bug report on these?
I think they are valid schema rules (though I don't know schema very 
well - I wasn't the author of the schema files that I'm using)

Thanks,

Dan


Dan Armbrust wrote:
> Now it is telling me that
> 
> javax.naming.NamingException: OID for name 'caseExactOrderingMatch' was 
> not found within the OID registry
> 
> for the following names:
> 
> caseExactOrderingMatch
> integerOrderingMatch
> 
> 
> Are these not supported, or am I still missing some schemas?
> 
> These stem from the following schema entries that I have:
> 
> # Integer -
> attributetype (1.3.6.1.4.1.2114.108.1.4.6
>     NAME 'tsInteger'
>     EQUALITY integerMatch
>     ORDERING integerOrderingMatch
>     SYNTAX 1.3.6.1.4.1.1466.115.121.1.27)
> 
> # Directory String - UTF 8 / Unicode - case sensitive
> attributetype (1.3.6.1.4.1.2114.108.1.4.4
>     NAME 'tsCaseSensitiveDirectoryString'
>     EQUALITY caseExactMatch
>     ORDERING caseExactOrderingMatch
>     SUBSTR   caseExactSubstringsMatch
>     SYNTAX 1.3.6.1.4.1.1466.115.121.1.15)
> 
> 

Mime
View raw message