directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject trying to load custom-schema data...
Date Thu, 19 May 2005 17:36:56 GMT
I'm trying to load up the Apache LDAP server for the first time, and to 
complicate things, my data adheres to a custom schema.

I have not loaded the schema into the Apache server yet so, when I try 
to load my data, I get errors like this:


javax.naming.NamingException: OID for name 'codingScheme' was not found 
within the OID registry at 
org.apache.ldap.server.schema.GlobalOidRegistry.getOid(GlobalOidRegistry.java:195)
at 
org.apache.ldap.server.schema.GlobalAttributeTypeRegistry.lookup(GlobalAttributeTypeRegistry.java:134)
...

and then errors like this:


javax.naming.InvalidNameException: codingScheme=Automobiles, 
dc=CodingSchemes: [LDAP: error code 34 - failed to add entry 
codingScheme=Automobiles, dc=CodingSchemes,dc=lexgrid,dc=org:
org.apache.ldap.common.exception.LdapInvalidNameException: Parser 
failure on name:
	codingScheme=Automobiles,dc=CodingSchemes,dc=lexgrid,dc=org
Antlr exception trace:
line 9:25: unexpected token: ,
	at 
org.apache.ldap.common.name.antlrNameParser.attributeTypeAndValue(antlrNameParser.java:181)


I presume this is because I haven't loaded my schemas.  Am I on the 
right track here?

I found this documentation: 
http://directory.apache.org/subprojects/apacheds/users/plugin.html

and I'm going to try to go through that process now.  Please let me know 
if I'm on the wrong track entirely.

Thanks

Dan

Mime
View raw message