directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrique Rodriguez <>
Subject Re: svn commit: r161903 - directory/network/trunk/src/java/org/apache/mina/common/
Date Wed, 20 Apr 2005 20:25:29 GMT
Collections API javadocs use the term 'resize' and that appears 
elsewhere (AWT).  Maybe:

public void setResizable(boolean resizable)

... and ...

public boolean isResizable()


Alex Karasulu wrote:
> Ok I see what autoExpand is for now a buffer that can grow 
> automatically.  This is why slice() and other operations may not seem 
> reasonable anymore from an implementation perspective.
> Makes sense but 'autoExpand' there has to be a better name out there.  I 
> did not get it until I read the docs.  Perhaps there's a name that you 
> can use that better expressess the functionality without requireing the 
> user to have  to hit the javadocs.
> Just my $0.02,
> Alex

View raw message