directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [GUMP@brutus]: Project mina (in module mina) failed
Date Tue, 08 Mar 2005 17:14:19 GMT
Trustin Lee wrote:

>Hi,
>
>On Tue, 08 Mar 2005 08:59:11 -0800, Brett Porter <brett@apache.org> wrote:
>  
>
>>Gump currently runs on JDK 1.4, and there is also a 1.5 build nightly.
>>
>>Do you require Java 5, and is that wise? I thought the min requirements
>>would be 1.4.
>>    
>>
>
>MINA requires Java 5 only for SSL support.  It runs OK in 1.4 if you
>don't use SSL. :)
>
>Trustin
>  
>
I think it would be a good idea to split this into a mina-jdk5 
subproject that provides the SSL support in a pluggable way. Is that 
possible?

Otherwise, chasing errors on a 1.4 platform could be a bit sketchy. 
You'll get class not found exceptions when ssl gets enabled.

- Brett

Mime
View raw message