directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tencé, Vincent" <vte...@optimuminformatique.com>
Subject RE: [janus] New name
Date Thu, 06 Jan 2005 13:57:15 GMT
I'm hearing you guys, and the majority seem to favor option 2, i.e. Apache
Authentication and Authorization Framework.

Didn't realize the package names had to change as well (what a pain). Phil's
made some nice suggestions, and I'm thinking of using either aaa or authx
for the package name. I'd like to know what you think about this.

Thanks,
- Vincent

> -----Original Message-----
> From: Phil Steitz [mailto:phil@steitz.com]
> Sent: January 6, 2005 1:08 AM
> To: Apache Directory Developers List
> Subject: Re: [janus] New name
> 
> 
> Tencé, Vincent wrote:
> >>On Wednesday 05 January 2005 14:19, Noel J. Bergman wrote:
> >>
> >>>Is it sufficiently generic?  Security has all sorts of 
> >>
> >>connotations.  Is
> >>
> >>>Janus specifically an AAA framework?
> >>
> >>I agree that Security Framework could mean anything from 
> >>encryption to AAA to 
> >>security access system in buildings and more.
> >>
> >>triple-ay seems more reasonable.
> > 
> > 
> > I agree that Security is maybe too generic, but it 
> generally refers to
> > Authentication and Authorization Services in the Java 
> Server world. The
> > feedback I had from AAA is that nobody knows what it means, 
> it's rather
> > cryptic. In that respect, I'd rather include Security in 
> the name, or
> > explicitly Authentication and Authorization. 
> > 
> > So I would favor:
> > 1. Apache Security Framework
> > or
> > 2. Apache Authentication and Authorization Framework
> > 
> > WDYT?
> > 
> > - Vincent
> 
> Among the 2 above, I would definitely favor 2., since I agree that 
> security is too broad.  I also hear you about people not knowing what 
> aaa is. I remember asking Alex once what "AAA for Avalon" meant ;-)
> 
> Another short, boring, but widely used name that captures much of the 
> guts of what is going on in Janus is "authZ", which we could use as a 
> package / artifact id root, postponing selection of a "product-like" 
> name until the community develops more.  Sort of like the old "ldapd" 
> name.  I know technically it should be "authZ + authN" (like 
> 2 says), so 
> maybe just "auth" or "authX"? Just a thought.
> 
> Phil
> 

Mime
View raw message