directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <p...@steitz.com>
Subject Re: [site] building and deploying part II
Date Tue, 11 Jan 2005 04:44:55 GMT
Brett Porter wrote:
> Quoting Phil Steitz <phil@steitz.com>:
> 
> 
>>I was running maven 1.0 initially, which would not start after the 
>>plugin:install below (looking for plugin-parent-1.0/Plugin.Jelly), 
> 
> 
> I think there was a typo - you should plugin install from the site subdirectory.
> Maven should have warned about this really.
> 
> 
>>so I 
>>upgraded to 1.0.2.  I assumed that the plugins were installed in .maven 
>>so did not rebuild after changing $MAVEN_HOME to point to 1.0.2.  Do I 
>>need to rebuild the site plugin?
> 
> 
> No, unfortauntely for backwards compat. plugins are still installed to
> $MAVEN_HOME/plugins (you can manually copy them to ~/.maven/plugins if you'd
> like though).

OK, so I will just rebuild the site plugin and that should be fine.
> 
> 
>>One funny thing that I have seen a couple of times in the last few days 
>>is apparently incorrect status/diff info from svn.  I did status and 
>>diff and neither picked up the changes to project.xml and 
>>project.properties committed today.  I then updated and saw the changes. 
>>  Are others seeing this kind of thing?
> 
> 
> This is as designed. svn status shows local changes (not remote changes
> waiting), svn diff does likewise (compares copy in .svn/text-base to current).

Doh! Thanks. Time to go RTFM (again).

Phil
> 
> Cheers,
> Brett
> 


Mime
View raw message