directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrique Rodriguez <erodrig...@apache.org>
Subject Re: svn commit: r123114 - in incubator/directory: eve/trunk/core/src/java/org/apache/eve/jndi/ibs ldap/trunk/common/src/java/org/apache/ldap/common/util ldap/trunk/common/src/test/org/apache/ldap/common/util
Date Wed, 22 Dec 2004 22:20:50 GMT
They are identical.  GMT is the "civilian" name, UTC is the 
international name defined by the UN as the initials would appear in French.

Z-time format is used in the RFC's and drafts.  The "Z" will appear in 
the timestamp and LDIF exports and since it's common in LDAP and 
Kerberos to view dates like that, I don't find it less clear.  Less 
readable for most Java developers, maybe ... normal if you view Ethereal 
captures or these RFCs.  I would rather not change it.

Defining it once is a good point though, as a constant like Z_TIME, 
which I would find even clearer and, as you noted, it is creating 
objects unnecessarily.

-enrique


Brett Porter wrote:
> I've always used UTC. It is slightly different from GMT isn't it?
> 
> Quoting Berin Loritsch <bloritsch@d-haven.org>:
> 
> 
>>Brett Porter wrote:
>>
>>
>>>erodriguez@apache.org wrote:
>>>
>>>
>>>>+      date.setTimeZone( new SimpleTimeZone(0,"Z") );
>>>> 
>>>>
>>>
>>>Is this just getting GMT? I would speculate (though have never tested 
>>>whether it performs any differently), that TimeZone.getTimeZone("GMT") 
>>>would be better, and is at least more readable.
>>>I also believe it to be immutable, so you can use it a static instance 
>>>rather than recreate it each time.
>>
>>
>>I agree.  Either "GMT" or "UTC".
>>
>>-- 
>>
>>"Programming today is a race between software engineers striving to build
>>bigger and better idiot-proof programs, and the Universe trying to produce
>>bigger and better idiots. So far, the Universe is winning."
>>                - Rich Cook
>>
> 
> 
> 

Mime
View raw message