directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <>
Subject Re: svn commit: r123114 - in incubator/directory: eve/trunk/core/src/java/org/apache/eve/jndi/ibs ldap/trunk/common/src/java/org/apache/ldap/common/util ldap/trunk/common/src/test/org/apache/ldap/common/util
Date Wed, 22 Dec 2004 20:21:19 GMT
Brett Porter wrote:

> wrote:
>> +      date.setTimeZone( new SimpleTimeZone(0,"Z") );
> Is this just getting GMT? I would speculate (though have never tested 
> whether it performs any differently), that TimeZone.getTimeZone("GMT") 
> would be better, and is at least more readable.
> I also believe it to be immutable, so you can use it a static instance 
> rather than recreate it each time.

I agree.  Either "GMT" or "UTC".


"Programming today is a race between software engineers striving to build bigger and better
idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far,
the Universe is winning."
                - Rich Cook

View raw message